Please Note the minimum browser requirements
- Google Chrome release 59 and higher
- Firefox release 54 and higher
- Microsoft Internet Explorer 11 and higher
- Microsoft Edge release 40 and higher
- Apple Safari 11.0.43

Safari Users
Safari is not supported. All Safari users will need to employ Chrome as the browser.

iOS Users
Users with iOS8 can now use PerformanceNet.